zoj 1942 Frogger

发布于 2020-02-11 23:39:48

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.


Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2 <= n <= 200). The next n lines each contain two integers xi, yi (0 <= xi, yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.


Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.


Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0


Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

关注者
0
被浏览
514
1 个回答
  • 面试哥
    面试哥 2020-02-11
    为面试而生,有面试问题,就找面试哥。
    #include <iostream>
    #include <cstdio>
    #include <string.h>
    #include <math.h>
    #define MAX 2000000000
    #define eps 1e-9
    using namespace std;
    struct point
    {
        double x,y;
    }p[205];
    double map[1010][1010],dis[1010];
    bool flag[1010];
    
    int dbcmp( double a )
    {
        if( fabs(a)<eps )  return 0;
        return a>0?1:-1;
    }
    
    double dijkstra( int sta,int n )
    {
        int i,j,mark;
        double mini;
        memset( flag,0,sizeof(flag) );
        memset( dis,0,sizeof(dis) );
        flag[sta]=1;
        for( j=1;j<n;j++ )
        {
            mini=MAX;
            for( i=0;i<n;i++ )
            {
                if( !flag[i] )
                {
                    if( dbcmp( map[sta][i] )!=0 )
                    {
                        if( dbcmp( dis[i] )==0 )   dis[i]=map[sta][i];
                        else if( dbcmp( dis[i]-max( dis[sta],map[sta][i] ) )==1 )
                            dis[i]=max( dis[sta],map[sta][i] );
                    }
                    if( dbcmp( mini-dis[i] )==1 && dbcmp( dis[i] )!=0 )
                    {
                        mini=dis[i];
                        mark=i;
                    }
                }
            }
            if( dbcmp( mini-MAX )==0 ) break;
            sta=mark;
            flag[sta]=1;
        }
        return dis[1];
    }
    
    int main()
    {
        int n,i,j,co;
        double temp;
        co=1;
        while( scanf( "%d",&n ) && n )
        {
            for( i=0;i<n;i++ )
                scanf( "%lf%lf",&p[i].x,&p[i].y );
            memset( map,0,sizeof(map) );
            for( i=0;i<n;i++ )
                for( j=i+1;j<n;j++ )
                {
                    temp=sqrt( pow( p[i].x-p[j].x,2 )+pow( p[i].y-p[j].y,2 ) );
                    map[i][j]=temp;
                    map[j][i]=temp;
                }
            printf( "Scenario #%d\n",co );
            printf( "Frog Distance = %.3lf\n\n",dijkstra( 0,n ) );
            co++;
        }
        return 0;
    }
推荐阅读
知识点
面圈网VIP题库

面圈网VIP题库全新上线,海量真题题库资源。 90大类考试,超10万份考试真题开放下载啦

去下载看看